--::Imperial Vogue::--

This page uses frames, but your browser doesn't support them.

This page uses frames, but your browser doesn't support them.


So, you finally got a date with future Mr EH, AbsoluteK (otherwise known as the Internet Officer, Fleet Admiral, and all round cute, fluffy, hot sex god Canadian). You're flying home in your shuttle with the butterflies from asking out such an absolutely gorgeous bloke still swirling in your stomach when your stomach suddenly plummets to your ankles with the weight of a lead balloon. Oh Krath. What in the hell are you going to wear?

Never fear, though, Vogue is here! With vast professional experience, we will tell you exactly how to prepare for this monumental date. With the aim in mind of getting the delectable Mr AbsoluteK out of that tight constrictive uniform and into something... a lot more comfortable...

One Week Before the Date:

Now is the time to find a few items that you might wear/intend to wear if you lose those extra couple of pounds. Number one on your list of priorities today is to go to the gym and work on those troublesome areas of flab and cellulite (yes, we do all have them). If you are intending to wax before the date, stop shaving today. Next (post shower of course), check your wardrobe for possible outfits. If there are none, it's time to get out that Credit Card and head off to the Corporate Division Shopping Mall on Aurora Prime.

This being a "date" of the highest degree - we're all relying on you to er... be successful - it's absolutely IMPERATIVE that you buy new underwear. We insist. You will feel so much more confident about slipping out of any items of clothing that might end up being extraneous to requirement if you at least have something utterly enticing underneath. On a note of caution, buy something that is not only sexy, but that you will also be comfortable in. Don't buy a red lace thong if you're going to be trying to tug the thong out of your arse all night (how unsexy does it get?).

Next, consider what impression you want to make on your Fleet Admiral. There are, as with many things, several that could be made. First and foremost, do you want to go with the "I find you incredibly attractive - would you go to bed with me?" look? Or would you feel more comfortable with the more reserved "I am a sex goddess!" look? It's time to decide. Or, if you can't decide, buy the entire store full of clothes and take back what you don't use next week.

Two days before:

Call all your girlfriends and tell them you're going out with AbsoluteK. They will be horribly jealous, and will bolster your self-esteem enough to feel like the sex goddess you are. Your very best friend will tell you (quite rightly) that he's not good enough for you, but that you owe it to womankind to get him into bed with you - he is after all the Fleet sex object/pin-up. She will also lend you her favourite pair of shoes (which you've been dying to get into), her cute, sexy, slimline black velvet handbag, and a bottle of GoldSpot.

Book an appointment with the beauty parlour for the morning before the date. Make sure they include a leg, bikini-line and underarm wax, and don't miss out on a facial, having your eyebrows professionally plucked, and perhaps a pedicure and manicure too. How far does your budget stretch?

Book an appointment with the hairstylist. Make sure they know exactly what you want. And that does not include crunchy bouffant hair! In fact, they should avoid this at all costs. Make the appointment for the evening, two hours before he's due to pick you up. Make sure you have a headscarf with you. If your hair gets blown to bits, he's not going to want to succumb to your seductional charms.

The morning before:

Attend your beauty parlour appointment.

Take a long soak in the tub, keeping your newly pedicured feet and manicured hands OUT of the hot water as it will peel your nail polish otherwise. Take a nice book to read and add some moisturising bath lotion to the tub. By the time you're done, you'll not only feel like a sex goddess, but look and smell like one too. On a note of caution, make sure it's a book you don't mind destroying - just in case you drop it into the water.

Towel dry and put some clothes on. Take your headscarf and go to your hairstylist's appointment. Once done there, put on your headscarf and return home.

Remove old horrid clothes. Add deodorant and perfume in relevant areas - we especially like the idea of a trail of scent leading inexorably towards... (well, I think you get the idea). Add underwear and jewellery. Then add makeup. Allow makeup to dry. Add sexy dress. Add shoes.

You are now ready for your date. Make sure you pack your handbag with the following before your date arrives:

The GoldSpot your best friend lent you,
Your cellphone (in case it all goes disastrously wrong and your best friend has to pick you up)
Your house keys (well... you don't want to invite the poor - really very gorgeous sexy pin-up - bloke in for "coffee" and not be able to find your keys, do you?)
A credit card/money (double dutch is always good on a first date)

When your doorbell rings:

Do not run for the door like a crazed loon. Yes, it's tempting. Yes, it is AbsoluteK. But be cool. Be calm. Be... seductive. Keep the poor guy waiting a little while. When you do open the door, make sure it is with a warm, welcoming smile on your face - and a wicked glint in your eye. This first contact will be the deciding moment for the whole date. Make sure he knows exactly what you want - without saying the words.

During the date:

Be funny, be witty. Do not be brash. Laugh at his jokes, but do not laugh too loudly. When the cheque comes at the end of the meal, offer to pay half. Do not insist. He will, as a gentleman should, tell you that he will foot the bill.

On the doorstep as he's dropping you off:

*DO* kiss him goodnight.

*DO* invite him in for coffee.

If he says no, club him over the head with your cellphone and force him into the house.

Once inside:

Actually make him coffee. This will disarm him, and make him unsure of your intentions. Make yourself a cup, and sit and talk with him whilst drinking it. This is your chance to go in for some outrageous flirting. Gauge his interest. Is he leaning in close? Is he smiling a lot? Is he staring down your cleavage with marked interest? If the answer to all those questions is "yes" you either have a piece of celery down your front or he's very interested. Slip away (after making a delicate ladylike excuse) to the bathroom, and slip into something more comfortable. Removing the dress and slipping into a black satin robe should do the trick.

On return, make an entrance. Stand seductively in the doorway, gazing at him. Your Fleet Admiral pin-up gorgeous sex object will now either a) run for the hills or b) stand up, cross the room in long, manly strides and take you in his arms before asking where the bedroom is. We're betting it'll be option b!! If it's not b, he's an idiot male who knows nothing, even if he is one supremely hot cookie.

Assuming it's option b, take your conquest into your bedroom and er... conquer him. He'll soon be running back for more.

Back


...Are Belong to Us

First, a bit of history. The Imperial Star Destroyer Avenger was the first flagship of the Emperor's Hammer. It was eventually upgraded to a Super Star Destroyer (probably using some strange tricks of the Force! :P). When the Sovereign class Super Star Destroyer became the new flagship of the fleet, the Avenger was given to the Dark Brotherhood to serve as its command ship.

I was approached in December 1999 by the leadership of the Dark Brotherhood. They felt that the Avenger was not performing as well as it should. I was offered the position of Commodore of the Avenger and given the task to restore it to its former glory. At that time I was serving the ISD Grey Wolf as Wing Commander and I knew that I would need help to accomplish this daunting task. After some long talks, I managed to convince my best Commander, Shups of Crusader squadron, to follow me and become my Wing Commander. This was one of the best decisions I could make for the Avenger as Shups not only became an excellent Wing Commander but he also brought most of Crusader squadron with him. Those men (RacerX, Black Revenge, Jeff Tiger Loruss, Smitroc) formed the core of the new Avenger. They became very active and dedicated Squadron Commanders.

One of the first things we did when we took command of the Avenger was to make extensive use of IRC. We took a chance and required that all of our CMDRs and higher had to be present on IRC at least a few times each week. It was a gamble, but it paid off. I believe this decision was instrumental in our success. The weekly Avenger Training Nights, where multi-player pilots could practice their skills and gain LoCs as well, also helped greatly.

After about a year of effort we managed to get our membership sufficiently high to justify re-opening Avenger Wing II. Smitroc became the first Wing Commander for that Wing since the great downsizing so many years ago. Surprisingly enough, Wing II grew very quickly under Smitroc's leadership. He unfortunately had to leave us and Jeff Tiger Loruss took his place as Wing Commander and the wing resumed its phenomenal growth. We also lost Shups who joined the Elite Avenger squadron with his old Crusader friends, they eventually all rejoined the Avenger, and I had the difficult task of finding a suitable replacement. Luckily enough, Shadowhawk was able to take over and Wing I has never been the same. A couple of months ago, Wing II became bigger than Wing I and has remained that way ever since.

As of this moment, the SSD Avenger is at 100 pilots, probably the highest it has ever been since it was opened. We are proceeding with the opening of the ISD Subjugator for pilot assignment. It would be the first time a new ship is commissionned since the opening of the Agressor Strike Force.

In 18 months, we successfully took a dying ship of 28 mostly inactive pilots and made it into a powerful force of 100 of the most dedicated, loyal and active pilots in the fleet. We only lost a handful of pilots during that time to AWOLs, the Reserves and other ships. I have never served with a prouder bunch (I had to say that, they scare the hell out of me sometimes)!

Editor's Note: We'd like to say a big congratulations to all those who made the opening of the ISD Subjugator possible. You guys worked hard, and you won through - well done!

Article courtesy of COM/VA Firefox


Reminiscences of an ex-Vice Admiral

Yes, I admit to it. I was a Vice Admiral of the Fleet. I recently decided to go back to my roots - or at least to the roots of the organisation and go back to being a Flight Member (not that I ever was one). So now I'm a Colonel; and let me tell you, it's great. I've never been so happy in the TIE Corps as I am right now. It's quite astonishing. In some ways, I suppose I should put it down to the Challenge, to Tornado Squadron, and of course to my supremely hot Commander.

In other ways, it's not all down to where you're positioned in the Fleet. A lot can have to do with what you really feel you want to deal with in the Fleet. So here's my look at why being a Flight Member is great and being a CA is not.

1: No responsibility
For the first time in months, I don't have to spend my week preparing a website that nobody read, used, or even looked at. I am bound to do nothing except send my CMDR an email every now and again saying I'm around. Even better, I can simply sit on IRC until he shows up and just tell him.

2: No reports to upload
Ok, so I was looking for work in the Security Office, but it's so nice to not have to upload reports every week. It used to bug the heck out of me, and that's for sure.

3: No reports to write
All of which said "website updated" without fail. One wonders why I needed to submit the things!

4: No people to counsel
I no longer need to know the AoWs, CoCs and Bylaws upside down and back to front. I can ignore people's little quibbles about all and sundry. All of a sudden the future looks bright.

5: I outrank my CMDR
Therefore, I can in fact order him to do my BSFs now!

6: Everyone on the Challenge loves me
How could they fail to?

7: They have to be nice to be cause they need me in the Squad
Got to love being a valued member of a 4-strong squadron.

8: I have more time to work on other projects.
For example this wonderful magazine. Aren't you all glad that I'm a FM again?

9: I have more time to fly TIE
Ok, so I'm obsessive, but in the 17 days since I joined Tornado, I've flown something like… (wait for it) 170 missions. Not bad for a few days' work.

10: I'm having fun
And that, let's face it, is what we all joined for.

There we have it. Ten good reasons why being a Flight Member is better than being a CA/VA. And now, I feel the need to plug a certain squadron on the Challenge. Tornado Squadron! That's right! Anytime, Baby!


GM Darth Chi-Long has very graciously submitted to an interview by Werdna, and this is the result. Without wanting to spoil the surprise further down too much (Shea right - Eds), we'd just like to yell this out like the crazy wee bunnies we are - CONGRATULATIONS!!!!!!!!!!!!. And if that doesn't spoil the surprise, we don't know what will. :P

Imperial Vogue: Could you please give us a brief outline of your career in the EH and DB (and whoever else you may have been :o)?

Chi-Long: Certainly...

I started in the Dark Brotherhood as an Obelisk Apprentice. Within two hours of joining, I had completed all the requirements of the SA and HM Wrath promoted me to the rank of GRD. I joined House Tridens of Tarentum (That was when all houses were all 3 orders), and the next day was given the Obelisk Brigade by QUA Bull. He also promoted me to JH that same day.

By the end of the week I was made DJK (I had redone Tridens' website for Bull).

The next week I received a promotion from GM Khyron to OW (that's two weeks after joining) for doing some graphics for him.

A short two weeks after that (A month after joining) then HRLD Blackhawk resigned in favor of me becoming HRLD. I was made DA Faethor, Herald of the Brotherhood. (if only it could be that easy for all of us! - Eds)

I redesigned the HRLD office, and continued to do many graphics for the whole EH, but I mainly concentrated on the Brotherhood.

DGM Jammin then resigned, and I was given the post of DGM by GM Khyron. I served there for quite some time and was made a DJM.

GM Khyron and myself both ran out of time, and so retired from our positions at the same time. For a short time I went and became Praetor to the then KHP Shaitan.

Again, I was called on to take up the office of the HRLD, and so I did. I also re-did the entire DB website and was granted the rank of DJP.

After being HRLD for a bit I grew weary of it, and spoke with Grand Master Paladin about joining the High Court of Inquisitors. He agreed, and gave me a spot on the court. A short time later I was made Tribune, where I stayed for quite some time.

I contacted GM Thedek and we created the Chamber of Justice. I was given the position of First Archon (Very similar to my HCI duties). I stayed there until I was promoted to the rank of GM.

Thedek had gone inactive and finally resigned, but because of a petty little disagreement, he passed me up for GM in favor of Zoraan. Zoraan in turn was one of the worst GMs known to DB history... and most of you know how that turned out.

Upon removal of Zoraan, I was placed on the Iron Throne.

IV: You’ve just been promoted to Grand Master of the Dark Brotherhood. What is your job exactly, and what tasks must you do for your position?

CL:Well... the following is what the DSC says about the Grand Master position...

"Grand Master (GM) - The Grand Master is the leader of the Brotherhood and is chosen for life by the Fleet Commander and Executive Officer. He has sweeping dictatorial powers over the Brotherhood and all positions and powers are granted by him. He serves as the keeper of the Dark Hall (the Brotherhood's base of operations) and Governor Plenipotentiary of Eos (the Brotherhood's homeworld). The Grand Master also holds the title of "Dark Lord of the Sith" but ascends over all three Dark Jedi Orders (the Sith, Krath, and Obelisk). Current and former Grand Masters are the only individuals throughout the Emperor's Hammer Territories who are afforded the title of "Lord." The Grand Master is also afforded the title of "Darth.""

Basically, I head up the Brotherhood. I come up with the direction and the ideas (With the help of the DC) to try to keep the DB the best SG (arguably) in the EH. I am also responsible for the day to day maintenance of the club, such as answering members emails, resolving DC disputes, etc.

I also appoint all DC members and approve/deny any promotions/position appointments.

Basically... if something needs to be done... I do it :)

IV:How are you coping with all the work you have to do now? We don’t want to see you with grey hair in a year’s time, do we? :o) (Oh, I dunno... Paladin looks rather distinguished. :P - Eds)

CL: My work load at first was astronomical. Zoraan and Thedek had left the DB an inactive mess. Thedek taking the domain from us also didn't help matters. I had many nights where I only got 3-5 hours sleep because I was working in my RL job and also doing several hours of DB work per day.

Now that the domain is pretty much self-sustaining, and I've got some good people in the DC, my workload has dropped to a manageable amount, and I'm getting a decent sleep every night :)

IV: Why do you think you got the GM job ahead of the other applicants?

CL: The main competition I had was GM Jac... a fine leader himself.

To be honest it was very, very close, and at one point I was told Jac was going to be GM again. Then at the EH meeting, Kawolski and Ronin decided to pick me instead.

I was quite qualified for the spot, with all the years of experience in the club, and I'd been passed over in the past... I think they just finally decided to give me a shot :)

I'm sure that the STRONG recommendations of GM Khyron and GM Paladin helped considerably.

IV: Do you think it was right to have the FC and XO to decide who the GM should be, or should it have gone to the vote of the Dark Council? I know it went in your favour as you are GM now, but would you like that method to happen in future incidences?

CL: The Brotherhood is a Subgroup of the Emperor's Hammer. The GM should be picked by the XO and FC...

Most times, the XO and FC have an outgoing GM who leaves on good terms... and makes a recommendation for a replacement, who is usually picked. The last two times a GM left haven't been as easy, which is why there was turmoil. I'm hoping to avoid that in the event that I should leave the position. I don't plan on leaving in a big huff ;)

IV: Do you have any big plans for the DB? Are there any big competitions or projects coming up soon?

CL: DGM Astatine is in charge of competitions and he is working on one as I write this.

My main plans for the DB were to get it back active again. We went through a period of such inactivity that it's been hard, but it's starting to come around now :)

After I get the DB self sustaining again, I'll look at making other changes... for the most part I've been doing everything one at a time, so as to not shock too many people at once:) (IE: Dissolving the Envoys, creating two new positions on the DC, etc)

IV: Do you have any goals for the Dark Brotherhood while under your control? (such as 500 more members, creating new features, etc)

CL: Again... I want to get the DB back to it's former glory... back when it was FUN to be a member, and there was always a "buzz" about what was going to happen next :)

Membership numbers aren't that important to me. I'd rather have 100 active members than 1000 members who are just there to bloat my roster.

IV: Do you still consider the DB as a sister organisation to the EH, or has it finally become an EH sub-group? How much say does the EH command staff have in the running of the DB nowadays?

CL: The CS has very little say... I run the DB.

But as I said above, the DB is a Subgroup. The reason it still holds the title "Sister Organization" is because we're the largest subgroup, and so we're afforded some special consideration.

Basically, the FC and XO are keeping an eye on the DB, to make sure I don't pull a Zoraan... but the DB is completely run by the GM.

IV: A lot of members consider the DB as a sideline to other groups in the EH, so they do less activity here than say in the TIE Corps. The only time when any activity for the members occurs is when a major vendetta is on. How do you plan on solving this major inactivity problem that has been in the DB for such a long time?

CL: By making the DB far more attractive than the other actions of the EH ;)

I remember when the DB was THE SG to be in... it wasn't that long ago, and I'm hoping to have it like that again :)

IV: Yourself and Knight Commander SWL Shadow have been sorting out the new Envoy system for the DB. What changes have been made, and roughly what will the Envoy system be like when it is complete? When will it probably open again?

CL: As seen in my announcements today, I am shutting down the Envoys. I can't have something in the DB that further bloats it.

The Envoys serve no purpose, unlike the GMRG, and so I have decided that for the time being they will be removed.

They may be opened in the future if I can come up with something for them to do, but until then they'll remain closed.

IV: The Dark Brotherhood website has only just been re-vamped, due to the old website (well, webspace) being less than reliable (is that a blatant understatement? :P - Eds). Right now it just seems to have the bare basics for a club website, compared to the last one, so are you planning to add any interesting features to the website later?

CL: More and more features are being re-added every day... we should have all of the features of the old website and more very shortly :) This is the job of the SCL, and thusfar Corran Force has been performing admirably :)

IV: As well as the DB website being re-vamped, the Emperor’s Hammer website is being done up too. It will be a huge database, much like the TIE Corps one, but will allow the rosters of all the subgroups. Will the Dark Brotherhood be joining it, or will we keep the database we have now?

CL: The Brotherhood will maintain it's own database. I have not been contacted by the XO regarding this big database. Of course, it is possible that we'll link ours with the main EH one... but no plans are officially in the works at this moment.

IV: What is your favourite Star Wars game? (not just computer, you could pick fiction, cards, etc)

CL: Star wars Trivial Pursuit

IV: When did you first get hooked on Star Wars? How big a fan would you say you were?

CL: I saw Empire Strikes Back when it was first released (I was 4 years old)... my parents took me to a drive-in to see it, and I fell in love with Darth Vader and the Imperials. I loved it ever since :)

I'm a moderate fan... I don't dress up like Darth Maul every day or anything, but I do obviously love the whole genre enough to have stayed with the EH as long as I have :)

IV: What do you love the most about being in the EH?

CL: The EH is a great place for me to vent my creativity. I get to do some great graphics and work for the EH, and the members seem to appreciate it.

My favorite thing is when I release a new graphic or website and the members go "WOW that's great!"

IV: When you aren’t the Grand Master, what else do you enjoying doing in the EH and Real Life?

CL: Well.. Currently I've been busy preparing for a huge move. Myself and my girlfriend (soon to become my wife... but she doesn't know that yet... shhhhh... you heard it here first folks :P ) are moving to Taiwan in 3 days (they've now been there for nearly a month - reports say they're doing well! - Eds). So that shall be a major change.

As for hobbies and interests... Kung Fu. I practice martial arts as much as I can, and that is one of the things I am going to Taiwan to do.

I also read a lot, and enjoy movies.

IV: What has been your greatest achievement in the EH? What do you feel the most proud about when you look back upon it?

CL: I don't really have one shining achievement that stands out from the rest in my mind... although I am very proud of the amount of work I've gotten done in the short time I've been GM thusfar :)

IV: If you weren’t GM of the DB, what other EH position would you like to have? (not FC though!) Why that position?

CL: Other than GM, I've only ever been interested in HI (High Inquisitor).

It's the other position I feel that I am qualified for and would be able to do well. Unfortunately (Or fortunately for the EH, I should say) HA Paladin is a FANTASTIC HI, and I hope he stays around for a long time to come.

IV: If you could pick half a dozen members of the EH for a special mission, who would they be? (pick out your favourite people)

CL: Acht... asking me to pick favorites...

To be honest, I don't really have any favorite members... I love you all equally ;) (awwww... tis a cute fluffy Grand Master! - Eds)


Cyclone Squadron is a Heavy Assault Squadron in Wing X on the ISD Challenge.

Email Squad CMDR if interested in joining.

Thanks to FL/CPT Crovax for the banner


The State of the DB

I suppose that I am very lucky. I had the fortune to join the DB when Khyron was GM, when everything was well-regulated and ordered. The Brotherhood was mostly active, and was very definitely the "place to be". Since then, things seem only to have gone downhill. I for one very much miss the Dark Brotherhood of yesteryear. I don't think I am the only one. With Chi-Long as GM, we turn our faces towards a new dawn, and wonder what's going to come next.

It is true that Chi-Long has accomplished a great deal in the last few weeks that he has been GM; we have a database again, after great upheavals, the DC seems to be finally settling into some semblance of order. Things seem to be looking bright, but still there are no competitions announced, still the inactivity that has been a demarquator of the DB until the present day continues. It is our great hope that Chi-Long can turn this all around.

I've been a Brotherhood member for 2 years and 7 months. It's a long time to spend somewhere, and there are others who have been here longer; active, hard-working members like myself. People who want to see this club rise once more from its ashes to be the phoenix it has been before. It's been through hell - and it's time to bring it back: stronger, better and more alive than it's ever been.

I am convinced that we can do that - not just the Dark Council, but all of us; everyone who wants to see this club come together and be something more than it is now - each one of us has a role to play.

Very recently, I was forced to stare myself in the face. A shadow of myself, let's say. And in that shadow I saw everything that I do not want to be. Everything I've done since then has been a reaction to that, and a positive reaction. The shadow played its role in bringing me to my senses again - and I am trying to play mine in bringing the DB back to its full capabilities. My influence extends only to one small House. If everyone approached their positions with the idea in mind that their influence stretched further than this - that it echoed through the corridors of the Dark Hall, that it touched all of us, all of our honour - perhaps we could accomplish more together.

I am honoured that I have been able to be instrumental in working on alliances between my House and others in the DB - I am indeed proud that this alliance lasted well over a month. It seems to currently be in hiatus, but this is something that one must expect in a club like the DB. However - I do feel that it is only by working together now that we can bring this organisation back from the edge of death.

It would be our greatest hour as members of the Brotherhood if we could transcend the boundaries of House and Clan to pull as one team, one club to achieve the activity levels we would all like to see. Let all the leaders of the Brotherhood come together and learn how best to motivate, how to encourage and how to win the best from our members. Let our members work together to recover what bad management has lost us. If we can do this, we can help the Dark Council and Grand Master to forge this club into something better than it was - we can make things better. Now is our time.

It is our role to ensure the survival and the betterment of this club; to help the Grand Master in achieving that. I for one believe that we can...

Article courtesy of M:CoG & AED/KE Mairin Astoris


Do my BSFs dammit! - written by FL/COL Mairin Astoris

Love is in the Air... - written by FL/COL Mairin Astoris

Werdna's Column - written by RSV/CPT Werdna Elbee


Has anyone else noticed, or am I the only one, that the "lovebug" is very definitely pervading the air of all Emperor's Hammer related areas? It seems that in a club where 90% of the membership is male, there's a startlingly large number of nascent and not-so-nascent love affairs going on. I know. I'm in one of the love affairs.

So... what is it that brings us all to the point where we date people we meet online? And why do we forever afterwards feel compelled to tell parents, friends, mere acquaintances that: "We met through mutual friends"? It's time to discuss the taboo of Internet Romance!

Of course, we all know that the Internet is BAD. My mother, for example, finds it absolutely ludicrous that I happily give out my cellphone number to all and sundry that I meet on the Internet. My sister is constantly trying to get me OFF the Internet so that she can use the telephone, whilst I protest with: "I'm talking to my boyfriend!" Parents and siblings all over the Emperor's Hammer may now proceed to wince in sympathy.

That's the problem. We generally ARE talking to our boyfriends. I've noted, over my time in the EH, that I've had precisely 1 (yes, that is one) boyfriend who wasn't a member of the club. I've also noted that rather than go out and find real life girlfriends, most men seem to sit in irc channels hopelessly chatting up all the women they come across. This is the nature of our sad, sad attachment to the Internet. And I really can't talk - my boyfriend is my Wing Commander!

It seems that the longer time goes on, and the more women join the EH, the more of us pair off and set up nest with other EH members. It's like a disease. And I'm sure a vast number of us remember all the EH relationships tried, failed and attempted to be forgotten (if some people would ever let us forget of course!). After all, for those who haven't fallen victim to the "EH Romance" yet, it's all a bit of a joke. Why, for example, would you want to be tied to someone living on the other side of the world from you? (been there, done that too). Let's face it, dating someone outside of your State/Country is a pretty stupid thing to do. So why do some of us do it? Why do we open ourselves up to such heartache and pain, even when we know that it's staring us in the face?

I can't answer that one, I'm afraid. It does seem to me, that the older you become in terms of Internet years, the less likely you are to actually succumb to the Internet "love bug". Or else, one simply chooses one's partner more wisely, selecting someone in your own country above someone in another country. Simple little things that make all the difference - like time zone.

Still, however much people look at us EH LoveBirds and laugh at us, surely we have as much chance of succeeding in a relationship in this topsy turvy galaxy as any of the rest of the world? Some you win, some you lose - isn't that always the way? I think we face several problems, with Internet Romances. Firstly, there is always a distance issue. It's rare - very rare - that you like someone who likes you back and just happens to live around the corner. It's a necessity that someone relocate, and that's not always a happy relocation. Not only that, but we face the prejudice of non-Internet users, who wonder why in the hell we can't get boyfriends without finding them on the Internet. Well, that's all very well, but everyone I've dated prior to my current boyfriend has been an absolute gimp in one way or another. Real Life boyfriend? Thanks, but no thanks.

So, in defence of all EH Lovers and EH ex-Lovers out there reading this: It might not correlate with the Dark Side, it might not be entirely Imperial... but who cares? It's fun sometimes, and it's bad sometimes - but where would the world be without Love?


Do you, as a fine upstanding Imperial Citizen, often wonder what you should be wearing? Does your cloak seem a little too down-at-heel for today's fast-paced galactic environment? Is your uniform just too impractical for everyday use? Fear not, fair comrade! Imperial Vogue is here to show you the way to a classier, more stylish future!

This week, we decided that we would discuss "style".

Style is one of those rather elusive words. We all know what it means, but it's so hard to put it into actual practice. Do you have style? The odds are on "Hell, no". So, why are we at the Vogue sitting here and telling you how to have style? Simple! We might not have it, but we know how to get it!

We just... didn't yet... *ahem*

Anyway. Onto the discursive about style. This elusive quality that we all seek, is really quite simple to find. Sadly, some of us never will. These are the drab basketcases that walk around in chintz and floral saggy trousers that look - and probably smell - frightful. We don't want to see that in the Empire! No! That's not for us Imperials, I hear you cry!

Chintz.... *shudder*. Anyway. After that quick digression, I think we can safely assume that chintz is NOT stylish. Please, for the love of Sith, remove all chintz from your wardrobe. It has no place there. Take it away and burn the stuff.

Being style gurus of the new EH Magazine, I can quite safely say that what we want to see in your wardrobe is black, it is red, it is purple. It is occasionally grey, but only that nice dove grey, not the hideous charcoal grey. Unless it's a very dark charcoal grey, in which case you can just about get away with it. Please, whatever you do, don't wear grey the colour of the new Dark Brotherhood website. It's sure to make you look just like the little dude in the graphic on the front.

In short, style is having the confidence to be as you are, to know you are who you are, and to love yourself for that. More than that, it is the confidence to tell other people that they don't have style, and to dictate to them how they should act to be more stylish.

Guess that makes me stylish!


A Date with AbsoluteK: Article by FL/COL Mairin Astoris

All Your Pilots Are Belong To Us: Article by COM/VA Firefox of the Avenger

Editor's Note: There was going to be an article about JediCon, but neither COL Callista (for shame) nor AD Michael Tolwyn (bad!) bothered to send us one. There was a bottle of wine up for grabs in return for an article on this one, but since they didn't send it, the Editors are going to share it between themselves to toast the success/failure of the magazine.


The FMC - What Does it Do?

G'day Ladies and Gentlemen, I am Admiral Michael Tolwyn, but most people know me as "Doc Mike". I am the Fleet Medical Officer and responsible for your cures, healings and holiday requests.

I often get the question "What does the Fleet Medical Corps (FMC)" do? The simple answer? Nothing. We have no gaming platform, hence we do not fly or fight like the subgroups. We do not debate like the Senate nor do we slice fighters or ships like the Corporate Division. We seldom have competitions. But that's got a reason. The MedCorps is made out of fine Doctors and Nurses who work not in the MedCorps itself but in their assigned unit in their Subgroups in the name of the FMC. Units, in this context, are in the TIECorps Star Destroyers or in the Senate committees.

When the publisher of the Vogue approached me, she asked me to "Tell me why we need you guys around". So, seeing as we do not real competitions and not even really work inside the FMC itself, one is tempted to answer this question with a "You don't need us". But that is more than untrue.

The Fleet Medical Corps is there to make the EH run smoother. With the Doctors and Nurses helping new cadets to get accustomed to the ship, solving matters and little problems between persons before they grow bigger and generally making some fun, they boost morale. They offer help wherever they can, be it in emails, be it on IRC chat or be it on message boards. They are the oil in the gears of the EH.

And this can be very hard job sometimes. In addition, we in the FMC have a unity I am very proud of. Without the pressure of competitions, the officers can focus solely on their units while getting all necessary help from the Corps itself.

It is hard to explain the spirit of the Corps. You have to feel it.

Article courtesy of MO/AD Michael Tolwyn


Aries: March 21st - April 19th

This month, you will find yourself surrounded with idiots. You don't know who they are or what they're doing, but they are all utterly incompetent. You're better than them! You're a bit of a prissy tart, really, aren't you?

Taurus: April 20th - May 20th

You've been having this feeling recently that there's more to life than simply mooching around in a field doing nothing. You're absolutely right of course. There's getting slaughtered in the Foot & Mouth epidemic too. With four hundred and fifty nine baccillae, you are the sickest cow, goodbye! (We believe this is strictly scientifically incorrect. However, we also don't care about that fact as it sounds good - Eds.)

Gemini: May 21st - June 21st

Double your trouble, double your fun, with double-cool, double-swirl, something something gum. Don't let the details get in the way, will you? You know you're right, and you're going to show the whole world that fact. At which point they will start hating you so much that you'll start being shuttled around in a large lead casket.

Cancer: June 22nd - July 22nd

"A plague on both your houses!" Well, that's true to a certain extent. Being a Cancer, you are prone to call down abuse and insults on everyone and everything you can find. It's not your fault you crashed that TIE - it was the Rebel's who was chasing you. Actually, it's never your fault, is it? How sickening.

Leo: July 23rd - August 22nd

Roar for me, baby, yeah... You're vain, quite egotistical, and the life and soul of the party. People pretend to like you, but really they're jealous. You don't have that many friends, as your aura of perfection tends to force them away from you. You're a bit of a sad loner.

Virgo: August 23rd - September 22nd

What? Round here? You mean you haven't been through Daedalus yet? Oh.. oh you poor little lamb. Never mind... We won't let the nasty people get you... (Oh, Kessler! We have a little job for you..! - Eds)

Libra: September 23rd - October 23rd

"Control! You must learn control!" Otherwise Yoda will fall off your feet and all your little packing cases will go flying to the ground. How sad. Really, you don't care. You're only in it for the prestige. You'd fit right into the Empire, only you're too stubborn to do it... On second thoughts - you fit right into the Empire. :P

Scorpio: October 24th - November 22nd

You spend so long going on about how great you are, that we're actually all getting sick of it. Here is your "Challenge" (that's a blatant plug - Werdna) (I know, it's meant to be - Mairin) (what about plugging something else? - Werdna) (Oh all right then - Mairin). Here is your "Immortal" for the month: TIE Fighter vs. Calamari Cruiser (with you in the TIE). If you survive, we'll bake you some cookies. If not, well... you're only half the man we thought you were. Literally.

Sagittarius: November 23rd - December 21st

Things to see, people to do... you're always in a rush. You need to calm down and savour the more simple things in life. Like ice cold chocolate milk on a hot day. Or sleepover parties and chocolate & rum fondue (*dribble* - Eds). Alternatively, please leave and let everyone else enjoy those simpler things in life without you cramping their style.

Capricorn: December 22nd - January 19th

Everyone needs to believe in something. You believe that you will have another beer. And maybe some more curry. And perhaps one of those onion bhajis over there. Oh, and a little more beer. And a little more curry. And a little more beer... I'm sure you get my Drift - you're probably eating it right now.

Aquarius: January 20th - February 18th

Help! I'm drowning! Blub blub blub... If only people would come to the rescue when you shouted for help. If only people cared enough to - oh wait. You didn't shout for help yet. Darn! You just ruined my cunning plan! How dare you?!?!!

Pisces: February 19th - March 20th

You seem to have this problem that as summer waxes and the spring wanes, you start looking a little green around the gills and giving off a pungent odour when away from your refridgerator for too long. Well you're a FISH! What the heck do you expect?!


OPS/FA Howlader steps up to the chair to be asked a few interesting questions... His chosen specialist subject is Howie, and his subsidiary chosen subject is Medals. Sir, you have one minute to answer as many questions as you can on your chosen subjects.

Imperial Vogue: You've been bugging me to interview you ever since I started up the Cosmo. Are you happy now?

Howlader: Yes, I am very happy, this interview gives me a chance for an ego trip, and I like ego trips :P

IV: You do pretty much the same job in both the TC and the DB. What does being OPS/CHAN entail?

H: Pretty much, I'm the MedalG0d, I approve and deny medals for half the people in the EH. Being the OPS Guy also means I get to yell at people for "defiling" my uniforms so to speak, and dish out witty sarcastic comments in my medal denial messages. Which is often very enjoyable :P

IV: Do you enjoy your work?

H: Of course, would I have stuck around doing the medals in the EH for the past two years if I didn't? :P

IV: How did you get the job?

H: Well, I've been the Chancellor of the Brotherhood for a little over two years now...so, here's how the story works. Back in September of 1998, Dev made me his Praetor (he was the Archon at the time, the medal guy). So I stayed with Dev for a while, then Morgoth did some...things that forced him to not be the Chancellor anymore, and Dev became Chancellor, and took the duties of Archon with him. So I followed Dev as Praetor to the Chancellor. By the time March of 1999 rolled around, Khyron and Faethor were retiring, and Stryker became Grand Master, and Dev his Deputy Grand Master. So a Chancellor was needed, and I got the job.

My TC career is quite different. Back in the day when Darth Vader was Flight Officer, he downsized a bunch of Wings, and the one I was commanding was one of them. So I became a Squadron Commander for a bit, then DV made me his Command Attaché...a week later, he retired, and Kawolski became FO. So I stayed with Kawolski for a while, then Havok retired, Compton became XO, and Dev became the TAC. Which left OPS open, and that position was filled by Fleet Admiral Bull. I joined the OPS Office in...April of 1999, as CA:OPS, and I stayed as the Command Attaché until January of 2000, when Bull retired, and I became the OPSGuy.

IV: Any inspiring words for any Howie fans out there?

H: Yes...two things:
1) Leave the EH before you become old and weird like me.
2) Make some friends in the EH before you do leave before you become old and weird like me.

IV: Are you going to win Mr EH this year?

H: Of course I am, because now I'm 16, and I'm legal in most parts of the world >:P

IV: Am I going to win Miss EH?

H: Yes, yes you are...(censored as not to be beaten about with a large sharp stick by General Darklord)

IV: How do you feel about the situation in the Brotherhood at the minute? Are there things that you think need improving now that everything is getting back on its feet again?

H: I think things are doing a lot better now that Zorro's gone...I didn't think he had the Grand Master suave that is needed to actually run the place (when he became GM) and I think I was proven right. There are still large pockets of inactivity in some of the Clans...which needs to be fixed... and there are some political issues that I'm not going to get into :P

IV: Lots of people get disappointed every week, when Mr Howie refuses to award medals. Is it just spite, or did you have a good reason for denying me those FIVE - count them - FIVE ISMs? Is there a good reason for most of your medal denials?

H: If it was spite, I would be denying all the medals that I see (Because I'm old and weird) :P But seriously, they get denied because a lot of people think "Ooh, I can award medals, I'll go award a dozen!"

IV: Do you think a lot of TC/EH medals are downvalued these days?

H: It seems that by comparison, a lot more upper-class medals are being awarded...but thats because people are doing more and more things. Which is good. But some medals ARE being a little bit devalued.

IV: What would you like to see happen to combat that problem?

H: What I want really, is people just to think before they click the award button...something I've been mentioning for the past 9 months or so :P

IV: Do you think that the CS works well together or is there a Weakest Link that you'd really like to vote off in the next round?

H: I think all the members of the CS are doing their best...but then...Ramos, you are the weakest link, goodbye.

IV: Unlucky for some! Is Vogue going to be the best EH magazine ever or what?

H: Although it may be hard to top the Cosmospolitan, I think with Mairin at the helm, she'll be able to pull it off. (she'd better be able to! - Eds)

I've started so I'll finish. Right here.


The Recovery of the IW

In the last few months, the Infiltrator Wing has grown by leaps and bounds. Was this caused from excellent planning? Is it luck? Or could it be the members of the Infiltrator Wing have pulled together so well, that it has become a desired place to be within the Emperor's Hammer? Regardless of what particular reason it may be, the Infiltrator Wing has grown from less than twenty active members to, recently, over one hundred active pilots.

Perhaps such things as online rosters, and other web pages, made a difference. Just maybe things like recruiting campaigns added to the Infiltrator Wing getting its name spread to people. Or even the members themselves have made the Infiltrator Wing a Sub-Group to take notice of.

The expansion of the Infiltrator Wing Support Division perhaps gave members a part of the Star Wars universe they looked for; flying YTs and Firesprays. Is this a change for the better? Is this change a flash in the pan, so to speak? Or is this the long awaited turn towards one man's dream? Only time will tell, and for those of us in the Infiltrator Wing, we cross our fingers and wait in anticipation.

Article courtesy of COM/CAP Trevor Rastyn of the Infiltrator Wing


Diplomacy is telling people to go to hell in such a way that they look forwards to the trip

All diplomats are masters of communications, and the various arts that this implies. The Empire has a long and glorious history of building some of the most skilled communicators in the Galaxy. Men like Pollux Hax, who served as the Emperor's Minister of Propaganda, brought this to the fore-front of Imperial Social policy. At the height of the Empire's Glory, the New Order encompassed millions of star systems, with billions of cultures, and languages. In order to ensure peace, communication was of the utmost importance.

The Emperor's Hammer, being the last notable vestige of the Old Empire, recognizes this. The Lord Ambassador has always held a significant position on the Command Staff of the Emperor's Hammer, as an advisor to Grand Admiral Ronin. The Lord Ambassador uses his skills as a communicator to bring peace and alliances to the various factions near Imperial Space. As the Lord Ambassador bring peace in the Territories, so does the Intelligence Division ensure internal peace, for as we know from the example of the Old Republic, a political group that is in inner turmoil cannot stand.

Diplomatic Services is a recently publicized Bureau of the Intelligence Division. The leaders of Diplomatic Services, and the Ubiqutorate realized that keeping the diplomatic arm of the Intelligence Division secret did not serve the greater glory of the Empire. Now, all Diplomatic personnel are publicly acknowledged officers of the Intelligence Division, to better serve the individual needs of the Sub Groups, and their Leaders. Liaisons will be assigned from within each Sub Group, each Wing of the Tie Corps, and every Clan of the Brotherhood of Dark Jedi.

Having a base of communications so wide-spread will better enable Intelligence to serve the needs of each group, whether it be stopping mutinies, and riots, or to ensure that spies do not infiltrate the Sub Groups, and wreak potential havoc. Rather than working in secret, every leader will know precisely what operations are being conducted within their Command, as long as Security is not compromised, through their Liaisons.

Public and Media Relations will publicize all important Intelligence operations as they pertain to the overall function of the Emperor's Hammer. This would include the public humiliation of all mutinies, and traitors to the Empire, along with all uncovered spies. Diplomatic Services is the bureau of the Intelligence Division that can change the mysterious and austere aura surrounding Intelligence to one of trust, and openness. Intelligence does not have anything to hide from all Loyal Sons and Daughter of the Empire.

I give my solemn warnings to all those who would turn their loyalties from the Empire, to a Rebel Cause: The Intelligence Division is watching you.

Article courtesy of LC Trevarus Caerick


SO/FA Nightflyer interviewed by Mairin Astoris: here

OPS/FA Howlader interviewed by Mairin Astoris: here

VE-FL/COL Mairin Astoris interviewed by herself: here

GM Chi-Long interviewed by RSV/CPT Werdna Elbee: here


Editor's Foreword:

This magazine has been a long time in the making - it's been bouncing around conceptually since the death of Cosmo, and is finally going to see the light of day. It's been a nerve-wracking time getting this all put together and getting it ready for publication. It's been one of those things that has started to take on a life of its own. For the last couple of days I've been living and breathing "Vogue". That's not to say the whole process hasn't been a great deal of fun, however! The real fun begins when people actually read the thing!

I really hope you enjoy this - it's been a long time in the making, and it's going to be around even longer (so we hope!). This is a magazine for the EH. If there's something you want to see in there, send it to us! Issue 2 is looming around the corner, and we have nothing to put into it. :P

Head Editor - Mairin Astoris
***
Property of the Emperor's Hammer and related SubGroups. Please view Disclaimer and Privacy Policy. Copyright 2001 © - All rights reserved.

This site run and managed by:
~ VE-FL/COL Mairin Astoris/Tornado 2-1/Wing X/ISD Challenge
~ VEA-RSV/CPT Werdna Elbee/M:FRG Phoenix

Additional Disclaimer: This magazine is intended to be funny. It is permeated with what we hope is humorous (like how the hell do you spell that word? - Eds). We do not intend to cause offence. If any is taken, we apologise in advance. :P


MAJ Bust Up sorts out all your troubles! Take it to a professional!

Sun Tzooh Matron, The Art of Lurve... (Part 1)

Quotes of the Month as kindly contributed by unwitting members of the EH

Production Logs - watch Werdna and Mairin flounder their way through the mire of producing the EH's most successful magazine in the world... EVER!


Well, this is a bit curious... in all the time I've been interviewing people, I've never interviewed myself. I can tell you now, it's a little surreal. But on with the show.

Imperial Vogue: So, Mairin, why in the hell are you interviewing yourself?

Mairin: Ah, you see, there are several reasons for that. The first is that I'm the head editor, I say what goes in the magazine - so if I want to interview myself and put it in, I damned well can. The second is that I spend all my time interviewing other people, giving them ego trips - well where's my ego trip?

IV: So in other words, you're just showing off?

Mai: Basically, yeah.

IV: So what do you actually do in the EH anyway?

Mai: I'm the cute, fluffy add-on to the ISD Challenge. Otherwise known as the WC's girlfriend. I'm also second in command of a House in the Dark Brotherhood, and a Flight Leader in the TIECorps. People keep asking me to join other things too.

IV: You're much in demand then?

Mai: Yeah, it would seem so. Of course, all they're really after is to get into my magazine.

IV: Don't you want them in your magazine?

Mai: I want them in my magazine when I want them in my magazine. It's a stylistic issue.

IV: It is?

Mai: Oh well, ok, no it's not. :P Generally I interview people either because they're fun to interview (Compton comes to mind as a really neat interview candidate), or because they're important, or because I simply can't think of anyone else to grill.

IV: So we'll never know why you're interviewing a particular person?

Mai: Sure you will! It's my job to interview people! That's mostly the only reason I do it. Plus it's often interesting hearing Old Fogies talk about the "good old days".

IV: It is?

Mai: Have you ever read the interviews?

IV: I do the interviews, lady.

Mai: So do I - so shut up and stop asking questions to which you know the answers!

IV: Bah, foiled. Do you ever get bored of running big magazines that capture the imagination of the club and spawn numerous little spin-offs?

Mai: Not really. I'm back for a second shot, and this time I think it's going to be much more successful. We're more organised, there are more people contributing. I think a lot of the problems that Cosmo faced were that it was literally a magazine produced by two or three people every couple of months or so when we finally had enough material to get it out there. It was very rare to have contributions from other people, and it was quite difficult to get medals for those that did contribute. What we're doing this time round is hopefully going to appeal to a much broader section of the Fleet.

IV: And how are you actually going to achieve that?

Mai: Well, both Werdna and I produced a suggestion plan and ran it by the Fleet Commander and Executive Officer for approval. The Cosmo was originally produced by three members - myself, Alanna, and Jarla. Sadly, Alanna and Jarla decided that they didn't want to be involved anymore after the first issue, so it was basically left up to me (and Dean-TO/HA Astatine as well). I've been very, very lucky - and indeed wise, I might say - in asking Werdna to work with me, and having him accept the offer. He has a much more stable approach than me, and I think that helps a lot.

Not only that, but by definition, Vogue is for the whole Fleet, encompassing every subgroup and sub-section of that Fleet, whereas the Cosmo was really aimed at pretty much just the TC and DB. I think we'll become bigger than the Cosmo ever was simply because we have that broader appeal.

[[Interview suspended so Mairin can go to a lecture and then go shopping for a girls' night with Jarla]]

Mai: Now... where was I? Oh yes, broader appeal. To a certain extent, I think that the Vogue is going to do that much better than Cosmo simply because we have a much more mature outlook on things. Whilst our basic intent is to be humorous, it is to be so without offending people - a line that I think we crossed with Cosmo on one or two occasions.

IV: So you won't offend anyone at all with this magazine?

Mai: (laughs) I wouldn't say that necessarily. What we're aiming to do is to offend as little as possible. Sometimes people take offence at things that you just can't anticipate. It takes all sorts to make a world, and definitely all sorts to make up the Emperor's Hammer.

IV: I see your reputation as a bitch is a little unfounded.

Mai: I wouldn't say that. >:) Just ask Trev how much of a bitch, I can be, and you'll soon hear quite another story, I'm sure! I think that art of being a bitch is actually knowing when to NOT be one. Always know who to suck up to, who to flirt with, and who to totally rip apart.

IV: So are you a difficult person to get along with?

Mai: Not at all! It's a case of finding the right way to "manipulate" me if you will. There are very few people out there who can get me to do something I don't want to do, and those that can are those that I truly respect. Of course, the problem with the respect issue is that as time goes on and I get older and dare I say it more secure with who I am and where I am, that circle of people whom I respect to that extent grows smaller and smaller.

IV: So who do you respect that much these days then?

Mai: Oh... well, I respect my Quaestor in the DB - Tron's one of the ancients of the EH; he's been a leader in practically everything, and not only that but a successful leader. His achievements are something I would respect him for, even if I didn't respect him for the way he's currently running Marka Ragnos.

IV: Anyone else?

Mai: Indeed. I greatly respect (and like) my Squad CMDR, LC Hicks. :) He's been enthusiastic, trusting, and supportive of me since I joined Tornado a month ago, to the extent that I felt at home there within the first few days of joining. I think he's damned good at his job, and I hope he sticks around a long time. :)

I also find GM Jac Cotelin an intensely inspiring figure. I think again that to look at Jac, one sees someone who has held practically every position in the CS, run the DB successfully - and then gone back to the rank & file and made a success of that too. Not many people could do that. I think with Jac, and this is something you don't feel with all highly ranked, well placed members, everyone feels special to have a little piece of his attention. That's really, so far as I can see it, the mark of a great leader.

There are a couple of others but I don't want to bore you all stupid - and give all them massive ego trips! :)

Really, I think it's safe to say that there are a lot of members in the club whose achievements I really, truly admire. Sometimes you can't always respect or like the person behind those achievements, but the achievements will always stand. I hope, when people look back at me in the future, they'll remember my achievements as well as my dippy crazy side.

At the end of the day, members join, members leave. The EH is its own little lifecycle, in a way. What is left is what we have done whilst a member. Perhaps one day I'll find a way to really leave my mark.

IV: Well... we can't say much more than that, folks! The lady said it all herself. And interviewed herself. :P Dippy cow. :P


Admiral Ozzel joins the Fleet: All thanks to MO/AD Michael Tolwyn, who single handedly convinced the great Michael Sheard to join our even greater organisation! A big welcome to Admiral Ozzel, and a big congratz to our lil Mikey. :)

Emperor's Hammer Summer Bash Announced: To take place 27th-29th July in Brighton, UK. Email Quake and Mairin if interested in coming along!

Imperial Vogue Unveiled: Imperial Vogue's first issue is now out (you're reading it, silly!). This magazine will replace both the Cosmo and the Battlecry. Read it and weep other magazine runners - this is the magazine to end all magazines!

New Appointments: VA Darkhill replaces FA Kermee as Science Officer - Congrats!
Belzedar Sleygar replaces Slegr as Chancellor of the Senate - Congrats to you too!
JediJawa replaces Karva as Grand Moff - Congrats, but we still love Karva!

AD Moreco awarded GoE: In return for his fine work as IWCOM. Note that the IW was one of the ONLY SubGroups to send us an article for the magazine, so he must be doing something right! >:)

COL Callista gets MoH: Awarded for her work in getting JediCon up together (still couldn't be bothered to send us an article tho; hmph! - Eds). COM/RA Manitsas of ISD Challenge was very nice and sent us Calli's brand new uniform!
Dark Brotherhood Database Fully Functional: Yey! :)
New EH Logo: Designed by LCM Tempest, who wins a GoE for the work.
Flight Officer gets FA: Wooooo! :)

Star Wars Mods: Star Wars Quake has been closed down, as has Star Wars Half-Life. Both are due to lack of interest and finance. Unreal Tournament: Emperor's Hammer is also in trouble.


SO/FA Nightflyer agreed recently to allow the Vogue to grill him lightly and then serve him up with a little light sauce. Here's the result!

Imperial Vogue: So... why did you agree to the interview in the first place?

Nightflyer: Hmm... To be honest, I'm not really sure. :P I've never done a magazine interview before, it seemed like a good chance to get a new experience.

IV: We're very into new experiences at Vogue. :P So on with the show... You're quite important in the EH - do you still have as much fun as your average flight member or is it difficult to keep yourself motivated?

NF: A bit of both, actually. Mostly, it's a day-to-day thing, keeping track of the same things and not doing too much different stuff. It's nice when we can get a little variety in, but my job description isn't quite as broad as that of a Flight Member. As with all the CS, we're all picked to do a certain task. For example, FA Howlader does medals, and only medals. FA Priyum does rosters. HA Astatine does the Academy and the Training Manual, and competitions. As it is, we're basically the duties of one commander divided up between ten people, not counting the FC and XO. So, it can get momotonous from time to time. :)

IV: Do you enjoy the task? And come to think of it - what is that task in the Security Office? :P

NF: The job of the Security Office is to investigate any incidents with personnel of the Emperor's Hammer, and if necessary, report them to the High Court for trial. The investigations can be fun sometimes, actually. Often, the investigative work itself will be boring, but I'll get a feeling of satisfaction and relief when I'm done.

IV: How do you feel about doing that? If you consider that the results of those investigations can result in serious consequences?

NF: Yes, I've thought about that a lot. Sometimes, I do feel bad that I may well be putting someone's EH career in ruins, but I have to remember this: People know what the rules are, and it's their choice to break them. I'm not doing something to them that they don't deserve, merely providing the reaction to their action.

IV: On the other hand, there must be circumstances when you find it very difficult to investigate. Do you handle cases that involve your friends the same as you do everyone else's cases?

NF: Sometimes, yes.

IV: Only sometimes? :P

NF: You'd be surprised how few people decide to break the rules. :) I have to keep that rule foremost in my mind when I investigate my friends. That, and usually I'll have to talk to them afterwards and try to convince them that it was professional, not personal. That's usually the hardest part of the job, and not one covered by my job description.

IV: How do you feel about the Security Office itself then - as an institution?

NF: I think the Security Office itself is something that people would rather do away with, but is here as a necessity, to cover the less desirable sides of people. It's not a fun job sometimes, but it has to be done by someone.

IV: So on the whole, do you enjoy being SO?

NF: On the whole, yes. :) There have been times where I've had some doubts, but usually I'm in the middle of a non-EH situation, so I just try to let it pass.

IV: You hold some other positions as well, in other subgroups, don't you? Would you mind listing them for us?

NF: Sure. Quaestor of House Aleema and Praetor (Glorified Secretary) to the GM, DB. Fleet Security Officer, Infiltrator Wing. Vice PRex of Security (Ret.), Corporate Division. Assistant Commander of Security, HF. I try to specialise in one area, as you can see. :P * NF waits for the cries of "Obsessed!"

IV: Heheh... so how did you get your mits on all those jobs then? :P

NF: Being an EH member for three and a half years was a good start, since I've been here for about as long as some of those subgroups have. :P Secondly, because of my position, I'm friends with a lot of senior EH members, so I have contacts pretty much everywhere. I try not to make them play favourites, though, and will gladly step aside if someone else wants the job. In the case of the HF and IW, I worked my way up from the bottom, actually.

IV: So do you enjoy doing these jobs or can it get a bit frustrating from time to time?

NF: Well, really, all the jobs meld into one, eventually. With the exception of QUA.

IV: So P:GM is a security job? :P

NF: *chuckles* It can be, sometimes. Not in investigations, but in conflict resolution. People usually see the investigative side of the Security Office, but we also get called in to settle disputes between members.

IV: Ahh, I see. So... being a member of the DB, how do you feel about events of recent months? Do you think it's getting better now, or does it still have a way to go?

NF: It has gotten better, yes. I think the removals of Zoraan and Thedek were unfortunate, but necessary. I feel that the DB can do pretty well under GM Chi Long, and speaking as his fellow EH command officer as well as a DB member, I wish him luck at it.

IV: Are there any improvements you'd like to see made in the DB, and what are they if there are? :P

NF: Realistically speaking, I think the DC and Assembly of Consuls should work together and see if they can't get an upward swing in activity moving. However, things have been really hectic lately, and they've tried the best they can, so I think it's only a matter of time. :)

IV: On a purely EH note, of course - how long can you last? >:) (feel free to include other information if you want tho! :P )

NF: Well, that depends on in what sense. :) Do you mean as a DB member, as SO, or in a more general sense, as in the EH overall?

IV: Everything of course. >:)

NF: Speaking specifically for SO, I think my biggest obstacle is my busy schedule outside the EH. It's hard to be able to balance the job with other commitments that I have, and to be realistic, a job in an online Star Wars club seems slightly less important than, say, schoolwork. :P Other than that, though, I have no problems with it. :) In the DB, we're in a stage of changes, and it would hardly be fair to walk out when nothing's been presented. Really, I can't judge if I'm not given anything, and the "anything" that isn't there is because of time, not lack of effort. I think we'll just have to wait and see.

IV: Last question - with Imperial Vogue replacing both EH Cosmo and Battlecry, do you think we'll reach the cult status of those two magazines, or are we going to totally eclipse them?

NF: Since you're picking up the readers of both magazines, you'll easily blow right past both of them. I can say for sure that I'll do my best to read them from time to time. :)

IV: I hope you'll read them every time. :P And now we're done. :P Thank you for allowing yourself to be grilled with a few slices of tomato. :P

NF: Thanks for putting up with me. :)


Obviously, A deliberate desire to ruin someone else's relationship instantly brands you as evil... WE'RE IMPERIALS! we're already branded evil! but there are times when killing love can be an act of charity... So here's part 1 containing 5 ways to do just that!

1) He's not good enough for my Flight Member!

One of your friends is seeing one of your FM's, cool, except he's a complete bitch to women! so whilst you forcefully laugh at his exploits, you don't want your FM being the next chapter in his legacy of womanizing. But the FM in question thinks he's the Emperor reborn!

Methodology

Get one of your FL's who is also good friends with the womanizing whore rat to ask him if the FM he's with 'goes or not?' and make sure he's equipped with a neat and discrete recording device. The whore rat should answer something like "I tie her up and she squeals like a lil piggy, she's gagging for my saber!!" at this point your FL returns the recording which you DO NOT LISTEN TO!!!

Now you wrap it nicely in gift wrap and drop it in her TIE's pilot seat, along with a little note attached saying 'PLAY ME' Suspecting a thoughtful gift she'll listen and get the picture...

Best Result: She dumps the whore rat without a second thought! And blood is undoubtedly going to be spilt (and so long as it's not hers you keep out!) She never looks at the whore rat again and takes a major dislike to men outside the squadron, which means the next guy who tries to pull her has got to treat her like a goddess, or be in the squad to even get close!

Worst Result: She thinks that the recording is the work of a voice manipulation droid, narrows down the suspects and leads to you! she decides you are trying to be 'Big Brother' and leaves the wing and moves to 'his' squad! and he gets to continue his womanizing antics and you still forcefully laugh at his antics...

2) I'm Losing My Mate!

You and your best mate did everything together... grew up together, went to the academy together, etc... that is until 'she' came into the picture... Like a Rancor trapped in a human body whose mission is to tame him until he marries her. He's never met the Toryn Everdawn or Abbey Dangerfield's of this universe yet, and so is sexually enslaved and following her every order! And now you want him back because the cantina just isn't as appealing without him.

Methodology

Find out their usual routine and send him lots of invitations for just him to attend parties (anonymous invites!) when he's about talk with people about that party last Saturday where that gorgeous lass scored with you and message him from noisy cantina's completely out of your tree saying 'oh mate, you should be here!'

Best Result: He hears the call of freedom again and strains his leash, against which she pulls and he breaks free! You just can't keep a pilot out of the cantina, no matter how hard you try!!!! So he dumps her, half way through 'Lee Evans Live On Coruscant' and a 1KG bar of Dairy Milk!

Worst Result: He's lost it big style, rubbing noses with her whilst she's saying 'Aren't we happy in our nest, pooky?' He gets used to cooking and cleaning and doesn't see you again as you remind him of that monster he once was!!! The cantina never is the same and you live a sadistic lonely life flying and sleeping...

3) I Want Her For Myself!!!!!

When you met your pal's new lady, Toryn Everdawn, it was lust at first sight!!! Even Better, you both share same interests and a sense of humour. He's said she isn't the one but won't dump her!

Methodology

You become her confidant (without appearing to be a bloke who cares about changing rooms and Eurasure's Early Works!) and make sure you're sat next to her when he goes on about the pod race that was on last night, and ask her "How's things?" sympathetically. Also bump into her when she's off duty, and suggest a little trip down to Aurora, then subtly lead the conversation onto him, pick up on his bad points and nod gravely!

Best Result: She looks on you as her best friend, but also a man with a tragically underused saber (if you take my meaning -MAJ Bust Up) She compares you favourably to your insensitive mate and looks forward to your little chats, where she hints you're a better option than your mate where you reluctantly agree and move in on her. :P

Worst Result: Your mate susses and goes mental, Toryn thinks you're Gay, or a stalker, both! None of your mates let you in the same room as their Girlfriends and your moral fibre is like a 'good Rebel' ("A good rebel is a dead Rebel- AD Striker") you end up becoming malicious cantina gossip and people point and laugh at you lots.

4) She's A COMPLETE BITCH!!!!!!

Clever, stunning and a total bitch, she's messes your CMDR around, then drops him for a better offer, you suspect she's been unfaithful too, but only you see through her deceit and treachery!

Methodology

Wait until she's cruising the cantina for new talent and your CMDR thinks she's at home watching some crappy game show, then go round and let him know you think you just saw his squeeze snogging some LCM in the cantina (Bad Brandon! :P -MAJ Bust Up) He'll not believe you, but describe one of her Ex's that one of her rather cute friends of hers described once. Finish with "does she always go for tall men?"

Best Result: Disillusioned, he ignores her denials and dumps her, you end up looking like an extremely loyal squad member and get promoted, then you all go get smashed in the cantina!

Worst Result: She has evidence that she was elsewhere, you are exposed as a conniving little [CENSORED], Your CMDR pledges trust in her until his dying day, her best friend (the cute one) tells them about your detective work on her Ex. He 'arranges' your transfer, meanwhile she's off with this Major, safe in the knowledge she'll never get caught!!!

5) He Needs Sorting, Big style!!!

You have a female friend who, strangely, you care for platonically. She's madly in love with this FL you have never met, he makes her happy, or did until recently... She confesses he's hit her a few times, but she daren't dump him!

Methodology

You got to make her leave him, given his obvious violent tendencies, this one isn't going to be easy... there's one sure way to do this: BLACKMAIL! you get invited to a lads night out and 'He' is there. you ask everyone of his mates about him and dig up some interesting info on him. Now you call in MAJ Bust Up who presents him with the info that his CMDR would be 'very interested' in hearing... In his former records, Gambling addiction & sexual history, he may not be adverse to the notion of setting your beloved friend free, quickly!

Best Result: He doesn't give a crap about her anyway & puts career first, and secretly admires your strong arm tactics & regains his rightful place in society as a sniveling little worm. He gently lets her down & she comes to her senses, but has no idea you were behind it!

Worst Result: Blackmail is illegal! (but not when there's promotions involved, eh Ricaud? -MAJ Bust Up) His mates tell you nothing of any use and puke in the TRN home which you have to pick up the cleaning bill for! He drops her anyway and she is inconsolable, and she begs him to take her back, at which point he tells her the truth and she never speaks to you again!

If you try any of the above, let us know how it goes, but beware we are NOT LIABLE for the consequences!


On Sun Tzooh Matron feature in issue 1:
(Werdna_LB) war is very much like...making love to a beautiful woman
(Werdna_LB) first you make sure that the soldier is standing to attention
(Werdna_LB) check out the lay of the land
(Werdna_LB) then find a hole in their defence
(Werdna_LB) and charge hard and fast
(Werdna_LB) <./fast show sketch...done bad>

(Mairin) ooh, we need a quote of the week section too. :P
(Werdna_LB) the "best use of mouth" award
(Mairin) LOL
* Werdna_LB was once a serious EH journalist before Vogue
(Mairin) serious sucks. :P

(Mairin) the idea of vogue is basically to bring together the best elements of cosmo and battlecry
(Mairin) monkey around with it some
(Mairin) shave its legs, give it false nails and some makeup, put it in a dress and sell it off as a new magazine. :P
(Werdna_LB) we sooo need that image for the front cover
(Mairin) maybe we can get that one of Brandy in a dress. :P
(Werdna_LB) this month's makeover!

Again, on the Sun Tzooh Matron feature:
(Mairin) do you like it? :P
(Werdna_LB) yeah, although I'm desperate enough to take it seriously rather than a joke
(Mairin) ROFL
(Werdna_LB) but it's still good either way
(Mairin) Can I put that in my quotes of the month? :P
(Werdna_LB) if you like
(Werdna_LB) ...I have little dignity left anyway
(Mairin) sure you don't mind? :) Only that made me laugh lots. >:)
(Mairin) awwww. :)
(Werdna_LB) gee...I'm glad it made YOU smile
(Mairin) :)))
(Werdna_LB) :(
(Werdna_LB) :o)
(Mairin) awww. :(
(Mairin) you'll find someone! :)
(Werdna_LB) I'll live...use the quote
(Mairin) just think! uni's around the corner!
(Mairin) first week at uni is like... mega shagathon. >:)
(Werdna_LB) yippee!
(Mairin) :))
(Werdna_LB) add that as a war cry in your art of lurve thing
(Mairin) lol
(Werdna_LB) actually, I have to shag around...I can't afford my own accomodation
(Mairin) hahaha
(Mairin) you make me laugh. :)
(Mairin) *adds that one too* :P
(Werdna_LB) which proves that the "sense of humour" thing isn't true!
(Mairin) :)))
(Mairin) yeah, we only like men for their big fat - *ahem* (Mairin would like to point out at this juncture that she was going to say: "We only like men for their big fat wallets" - Eds)


Werdna_LB: yeah, although I'm desperate enough to take it seriously rather than a joke (<-- on reading Sun Tzooh Matron)

Werdna_LB: actually, I have to shag around...I can't afford my own accommodation (<-- Uni looms then)

Mairin: Eek! I broke a nail! (<-- You're not meant to scratch that hard, love)

***Signoff RA|Oldsta (Drinky Winky) (<-- Tinky Winky's alter ego?)

Kessler: I really, really hate my Sidewinder. Precision Pro 2? Precision??? HA! It's like trying to guide a block of soap around a wet tile floor by blowing on it through a straw :P (<-- About as responsive as a dead sheep then?)

LC Hicks: No laughing at Kessler's score, he has a sucky joystick :P (<-- Well, honey, we did try and tell you!)

Astatine: It would make a change from the usual trash the Krath turn out (<-- on the concept of erotic fiction)

Mairin: I just blew my nose and a coco pop came out! (<-- They're supposed to go into your MOUTH not your NOSE)

Howlader: Potato (<-- Apparently this is cute, endearing and quotable. I think someone needs their head read.)

Alimet: finding notes that I wrote myself and trying to decipher them is funny :P "3 - nukes paper. 5 - read len, 150 ppegs, assglmbds. 6 - --/lgs"
Mairin: what the hell does that mean?
Alimet: I don't know :P

* RA|Mell is away - [top secret project] - at 08:37pm (<-- Not very secret top secret project we assume?)


Have we left out something that you're interested in? Should it be there? Why not write about it for us? Simply email your articles, jokes, interviews, reviews, news, and any other bits and pieces to Mairin & Werdna.

If you write for us regularly, and are a member of the TIE Corps, you even get to add a funky little "WRT" to your ID line! (e.g.: FM-WRT/LCM ***/Tornado 3-3/Wing X/ISD Challenge - and yes, that is blatant recruitment)

Now also Recruiting for:

Cyclone Squadron


Rage Against the Machine: Renegades

As I carefully unwrapped the newly purchased CD.. I wondered if Miack was exaggerating about how good the CD actually was... It wasn't until I slipped the silver disc into my hi-fi did I actually agree with him. Every track on the CD is absolutely brilliant. The now almost cliché screaming of abuse and expletives was music to my ears. There's a couple of live tracks and one includes a double with the Cypress Hill, which is defientely, something to listen to. The CD itself is worth buying for the excellent "Renegade's of Funk" which is what the album was named after. Defientely worth the £14.99 I paid for it.. Go out and get it you rock lovers!

Reviewer: Quake
Score: *****

~~~

Bridget Jones's Diary

We don't often have our momments.. But the Four Weddings Team have done it, yet again. The British Film Industry is currently somewhat hushed, and it's great to see a film like this hit Hollywood with such an impact. It's one of the only films I've seen where I have witnessed the entire audience in hysterics, even the most lacklustre person can sit down and really enjoy this film. Although some have put it down as a "Chickflick" there is appeal there for everyone, you won't be disappointed. Simply put, it's a classic. (and we especially liked Dan Cleaver and Mark Darcy shoving each other through plate glass windows to "It's Raining Men". HALLELUJAH! - Eds)

Reviewer: Quake
Score: *****

~~~

Geri Halliwell: It's Raining Men

Love the song, shame about the singer. Simply put, dearest darlingest Geri has neither the range nor the power in her voice to carry off this song. Buy the original.

Reviewer: Mairin
Score: *

~~~

Therapy?: Suicide Pact - You First

I've been into Therapy? since forever. Way back when they released Troublegum, I was one of the first that ran along and bought the thing, and every time I listen to it, I still think "Wow, this is one of the best records the 90s came up with". So when I poddled into my local record store and saw "Suicide Pact" I thought: "Cool! Therapy?!" and bought it. I was a bit disappointed. Therapy? have been one of the most seminal rock bands this side of the Atlantic, and it's always a shame to see something like that stagnate, but I get the feeling that this is what they've done. Their highest moment was "Troublegum" (1994) and "Infernal Love" (1995) only JUST ranks lower in my estimations. Sadly, my way of judging Therapy? is now: "Is it better than Troublegum". This definitely isn't. It has its highlights. It's technically brilliant - clean, sharp, perfect sound. It's heavy, it's rocking, it's the sort of thing you would probably prefer live to listening to on a CD. The fact remains however, that this is not Therapy? at its best, and it's certainly not representative of what they've done before. Whilst I'm still listening to it, and it's still growing on me, there are none of the instant hooks that permeated Troublegum and Infernal Love. A mediocre offering from a very good band.

Reviewer: Mairin
Score: ***

~~~

Manic Street Preachers: Know Your Enemy

This is another of those bands that I've been in love with since the early 90s. I have every single album they've ever produced. I was a bit worried about buying this one. The disappearance of Richey James in 1994 had a huge impact on the band, and the two albums they released following that were a bit sucky in my opinion. I actually found myself looking up at the ceiling as I loaded this CD up and pressed play, and suddenly fell backwards in surprise. They've gone rock again! Hallelujah! The sound is as bright and clear as you expect from every MSP album, the tunes are hooked to the max - listen to this and you'll be singing MSP for the next month!, and it's full of the good time vibe that the band have been missing for - well, forever. Whilst MSP seem not to have left their political roots behind they have moved into purveying a kind of music for the masses that appeals across the board. More power to them - they deserve the success. I'd love to see this at the top of the album charts; even if it won't happen, this is definitely the best album I've heard this year.

Reviewer: Mairin
Score: ***** (Read: ****************************** - Eds)


Love-Making is a great matter to a nation; it is the ground of death and of life; it is the way of survival and of destruction, and must be examined. Therefore, go through it by means of five factors; compare them by means of calculation, and determine their statuses:

One, Way,
Two, Heaven,
Three, Ground,
Four, Lover,
Five, Sex.

The Way is what causes people to have the same thinking as their lover; they may be given death, or they may be given life, but there is no fear of danger and betrayal.

Heaven is dark and light, cold and hot, and the inhibitional constraints.

Ground is high and low (breasts), far and near (and damned untouchable), obstructed and easy (boyfriend or no boyfriend), wide and narrow (amen), and dangerous and safe (watch out for the red heads).

Lover is experience, credibility, good looks, (Dutch) courage, and discipline. And knowing when best to strike.

Sex comes from organization, using your resources, and making sure that no one is home to hear her cries of ecstasy.

All these five no lover has not heard; one who knows them gets laid frequently, one who does not know them is rarely laid if ever.

Therefore, compare them by means of calculation, and determine their statuses.

Ask: Which ruler has the Way, which lover has the ability, which has gained Heaven and Ground, which carried out Law and strategy, which man is strong, which woman is ready, which reward and punish when you want them to, by means of these, I know victory and defeat!

A lover who listens to my calculations, and uses them, will surely get laid, keep him (and use him often); a lover who does not listen to my calculations, and does not use them, will surely never get laid. Don't even bother trying.

Calculate advantages by means of what was heard, then create charisma in order to overcome outside influences.

Charisma is the control of the balance of power, in accordance with advantages. Love-making is the Way of deception. Therefore, if unattractive, appear attractive, if a gimp, appear not a gimp, if near, appear far, if far, appear near.

If they have advantage, entice them; if they are confused, take them, if they are substantial, prepare for them (or they might squash you), if they are strong, subdue them, if they are angry, beware them, if they are humble, make them haughty, if they are relaxed, toil them, if (the legs) are united, separate them. Attack where they are not prepared, go into where they do not expect.

This specialized warfare leads to getting laid, and diseases may not be transmitted beforehand.

Before doing battle, in the bar with one's mates one calculates and will win, because many calculations were made; before doing battle, in the bar with one's mates one calculates and will not win, because few calculations were made; many calculations, sex, few calculations, no sex, then how much less so when no calculations?

By means of these, I can observe them, beholding sex or a gimpy evening at home with a pint of beer!


The Dark Brotherhood - Aha! I have you now!

The Fleet Medical Corps - The Professionals..?

The Infiltrator Wing - Dig those A-Wings, boys!

The Intelligence Division - ssssssh, be vewy vewy qwiet... I'm hunting webels!

Editor's Note: There would be more SubGroup Madness here if any SubGroups had bothered to send us stuff. We would like to say a big "Shame on you" to:
The Hammer's Fist
The BHG
The Imperial Senate
The Directorate
The Fringe
EH SW:CCG
We exclude the Corporate Division from this naming and shaming because they at least bothered to contact us and let us know they wouldn't get anything in on time for the release date.

The rest of you people are bad bad bad! Send us stuff next time!


Vogue Head Editor: VE-FL/COL Mairin Astoris
Vogue Deputy Editor: VEA-RSV/CPT Werdna Elbee

Thanks to all those who took part in the creation of this issue. They are:

News : TIECorps News Page, EH Domain News Page
Features : FL/COL Mairin Astoris, COM/VA Firefox
Editorials : FL/COL Mairin Astoris, RSV/CPT Werdna Elbee
Interviews : SO/FA Nightflyer, OPS/FA Howlader, FL/COL Mairin Astoris, GM Darth Chi-Long, RSV/CPT Werdna Elbee
Fashion : FL/COL Mairin Astoris
Horoscopes : FL/COL Mairin Astoris
Reviews : CA:XO/AD Quake, FL/COL Mairin Astoris
SubGroup Madness:
The Dark Brotherhood: M:CoG & AED/KE Mairin Astoris
The Fleet Medical Corps: MO/AD Michael Tolwyn
The Infiltrator Wing: COM/CAP Trevor Rastyn,
The Intelligence Division: LC Trevarus Caerick
Jokes/Fun Page : COM/RA Mell (MAJ Bust Up), FL/COL Mairin Astoris (Sun Tzooh Matron) & ENV/VA Andronicus (STM Concept), Quotes of the Month compiled by FL/COL Mairin Astoris, Production Logs courtesy of RSV/CPT Werdna Elbee

HTML, Text Graphics: VE-FL/COL Mairin Astoris
Hosting: WC/GN Darklord
Vogue Graphic: FM/CPT Shakur


Suitable for Netscape v4.7 and Internet Explorer v5.0+; best screen resolution=1024x768


Contents

Introduction

News

Features

Editorials

Interviews

Fashion

Horoscopes

Reviews

SubGroup Madness

Jokes/Fun

***

Staff/Credits

Recruitment


He's Talking Nonsense

(All opinions in this article are SHARED with the newsletter Vogue. Please sue them rather than little, old me) (How about just not suing at all? None of us have any money! - Eds)

Isn't this meant to be about the EH???

I'm currently in the reserves because I have a pack of exams coming up so I don't really know what is going on here in the EH. It could be dead for all I know.

So until I can get my EH career back on track, this article is just going to be about anything else that pops into my head. I'll try an make it entertaining, but 80% of the time it will probably just be me moaning on about injustice in the world, exam stress, how drunk I got last night and how I couldn't even pull in a brothel (technically that's true, coz I would never use one... I have some class).

By the time the summer starts I should be back in action though. Expect more fantastic articles and interviews from me, as well as a column that doesn't look like it was thrown together in a 5-minute break between studying Computing and Maths.

Tip Of The Poops

While writing this article I'm watching Top Of The Pops. Some of you may have heard of this TV programme. Others (i.e. those who aren't British) probably haven't. Basically, it's supposed to be a show where they have bands and musicians come on and play their latest hit.

I say "supposed" because it's nothing like it's meant to be. Bands and musicians don't come on because all the acts are pop groups who haven't got an ounce of talent between the lot of them. And even then, they don't actually appear on the show because they just send their music video in (lazy gits).

Technically they don't play "hits" either. The only way to get on the show now is if the record companies bribe them enough. Top Of The Pops is so influential with the teenyboppers in Britain that what they play WILL be in the Top 10 - no matter how crap it is.

The perfect example has just appeared on TV now. Geri Halliwell (of the Spice Girls) is currently covering, and massacring, "It's Raining Men." If you can't remember back to five years ago when the Spice Girls were famous, Geri was the fat, ginger one. She has changed a lot though, with a finely toned figure and newly blond hair. The face is still like a smacked arse though (Hallelujah! - Eds).

I don't know anyone who likes Geri Halliwell. (Nor do we - Eds)

She's number one. (RATS! - Eds)

Good Tunes

The charts aren't full of complete crap though. Hidden away in the depths of beautiful boy and girl bands, remixed disco hits (the originals are better), and Madonna re-launches, there are still some gems to be found. I highly suggest that you find and listen to these recent tunes, as well as look up their past work if you like the band:

Sing - Travis
Have A Nice Day - Stereophonics
Good Souls - Starsailor
Thank You - Dido (didn't she team up with that necromantic slime bucket Eminem? - Eds)
Star 69 - Fatboy Slim (actually, the B-Side is better)

Also there acts like Badly Drawn Boy, Feeder, Manic Street Preachers (see reviews section for a review of their latest album! - Eds), ColdPlay and DumDums, who all have albums out and are very much worth listening to.

Nu Metal has been excluded from my choices. Sure they are good when you first hear them, but then you realise that it's just a lot of shouting and badly played tunes. My suggestion to them bands is to chill, take some time out to learn how to play TOGETHER, and try and do something creative occasionally.